Group: I am bench testing an APM in an effort to become familiar with it.  I am struggling with loading parameters and then writing them to the APM.

When I LOAD parameters, what should I see?  I am testing by using downloaded file from adrupilot-mega "Maja Parameters file".  When I click "LOAD" on the Configuration/Adv Praeter List a small box pops up that says "NOTE:  26.10.2011 21:40:00 Plane: Skywalker".

So it appears that I am not doing something write to load the file.

Then as a follow up question, once I do get to the point when I can WRITE PARAMS, how do I double check to see if in fact that I wrote the correct params to the APM?

The WiKi on this area of the APM is a little sketchy.

Thanks!

Bret C

Views: 394

Reply to This

Replies to This Discussion

I hope someone can assist you with your issues!!

Thanks Joshua - this seems like it should be pretty straight forward, but my system does not seem to work as it should.  

can you please link to the files you are trying to use. also what AP version are you using

Michael:

Thank you for your reply.  I will do my best to give you more details.

I am using Mission Planner 1.2.32 MAV 1.0 on a PC Toshiba laptop running Windows 8.  The USB cable is plugged directly into the APM from the computer.  Te verify the connection is being made made from the PC to the APM, I can go to the Flight Data screen and observe the artificial horizon move as I move the APM.

Several parameter files were downloaded including, easy tar.param, maja.param and plane_PT60.param.

When I am in the configuration tab, Adv Parameter List - the screen is populated by parameters beginning with AHRS_BARO_USE ….  In an attempt to load a parameter file, I click the "load" button and go to for example Xplane a small pink box pops up "Saved Note, NOTE:PT60 RC aircraft for Xplane and OK at the bottom right of that small box"  When I click OK nothing happens.  Regardless of which parameter file I attempt to load, the same thing happens.

As a related question, how do I know what parameter file is already loaded?

The WiKi information on this area of the Mission Planner is very sketchy.

Thank you.  I appreciate your help Michael.

Bret C

Michael:  Also - it is unclear to me what is supposed to happen when everything goes well.  

Thank you. Bret C

Links to some of the parameter files I have tried are:

skywalker.param

    maja.param    

Thank you.

Bret C

I will answer my own questions here so others will have access to this knowledge in the future.  First I want to thank Jay S for spending time with me via Skype to resolve this.

It appears that my APM was working correctly.  The issue I was having was due to the fact that when I LOADED the parameter files, nothing visually happened to confirm that it worked.  Having no idea what to expect, to me - no feedback, met nothing happened.  But I was wrong.

You can tell that a new file was uploaded by the fact that some of the cells in the value column of the Mission Planner will be a different color.  The colored cells means that the value of the files that were loaded are different from what is written into the APM.  

When you click the "Write Params", the colored cells disappear because they are the same as those in the APM.

I hope this helps.

Bret C

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service