Les M
  • Male
  • NSW
  • Australia
Share Twitter

Les M's Groups

Les M's Discussions

Crashes when switching to Loiter

Started this discussion. Last reply by Andre K. Apr 30, 2013. 2 Replies

Hi Everyone,My quadcopter (APM 2.5) normally works extremely well with loiter, RTL and missions all working really well and have done since I built it. My problem is spectacular crashes when…Continue

Camera Gimbal Jittering

Started this discussion. Last reply by Les M Apr 25, 2013. 8 Replies

Hi Everyone,I have recently fitted a gimbal & camera to my Quadcopter (APM 2.5/2.9.1) with a video link. It was just a cheap chinese one similar to this:…Continue

Negative Altitude

Started this discussion. Last reply by Pierre Seguin Jul 8, 2013. 17 Replies

Hi Everyone,Have a 2.9.1 quadcopter which flies really well in stabilize mode but when I attempt to use Loiter or RTL, it takes off at maximum climb. It's easily recoverable by switching back in to…Continue

 

Les M's Page

Latest Activity

Pierre Seguin replied to Les M's discussion Negative Altitude
"One my autopilot APM 2.5 has the same negative altitude and I am sure it is not vibrations, because the autopilot is sitting on the bench in my lab and directly connected to my laptop. the indicated altitude vary from -60 cm to - 80 cm to 0cm then…"
Jul 8, 2013
Usman Qayyum replied to Les M's discussion Negative Altitude
"This problem happens to me as well. The baro shows negative values. The reason behind is vibration as pointed out earlier. The ardu uses Accelerometer z-axis (up/down) values in conjunction to sonar (<11m, if enabled) and barometric for altitude…"
Jul 8, 2013
Charles lakins replied to Les M's discussion Code to trigger strobe lights in the group ArduCopter User Group
"Hi Les If your anything like me you like to tinker and want to do this because you know somehow this is possible ,A while back I made a trade with a member for some parts and one was a light controller, it's made from dimension engineering…"
May 28, 2013
Les M added a discussion to the group ArduCopter User Group
Thumbnail

Code to trigger strobe lights

Hi Everyone,I would like to get some high intensity strobes going on my APM 2.5 While I can handle the electronic side of things, I am a bit confused with going about the code to drive them. There appears to have been a change in code around V2.6 (maybe someone can confirm this) and I think a lot of the examples around the forums are for pre 2.6 builds.... I would also like to select different flash modes depending on input ch 7 or 8. I currently have a remote GPS & arming LED's and would…See More
May 28, 2013
Andre K. replied to Les M's discussion Crashes when switching to Loiter
Apr 30, 2013
Andre K. replied to Les M's discussion Crashes when switching to Loiter
"Yes, I've seen mode switch crashes as well, motor stop. Always after loiter is unstable. Last crash happened when quitting follow mode, which is a guided mode.. See https://github.com/geeksville/arduleader/issues/66 for my logs. I also had…"
Apr 30, 2013
Les M posted a discussion

Crashes when switching to Loiter

Hi Everyone,My quadcopter (APM 2.5) normally works extremely well with loiter, RTL and missions all working really well and have done since I built it. My problem is spectacular crashes when switching into loiter. The vast majority of the time loiter works fine, but 3 times over the last few months I have have some pretty good crashes with loss of power when switching modes. The last one was last Saturday (logs attached) when it very gracefully flipped over and crashed to the ground.From the…See More
Apr 29, 2013
Les M replied to Les M's discussion Camera Gimbal Jittering
"Sounds very similar to my problem. I didn't find the source of the interference but could be coming from the 3DR. 1 thing I might try is changing the length of the cable as mine is very close to half wavelength @ 915Mhz (164mm)."
Apr 25, 2013
Brian Sigmon replied to Les M's discussion Camera Gimbal Jittering
"Hi Les, I had a similar glitching problem.  I found that some digital servos really don't like the 900Mhz telemetry radio.  Unplug the 900Mhz telemetry transmitter from the APM and the problem went away.  The analog servos and…"
Apr 25, 2013
Les M replied to Les M's discussion Camera Gimbal Jittering
"Just rerouted the cables to the gimbal, steady as a rock now! Adjusts itself to the copter attitude, can adjust it in-flight, everything works!Now that I've found the issue, going to use shielded cable which should make the fix permanent. Now I…"
Apr 25, 2013

T3
Richard Boyhan replied to Les M's discussion Camera Gimbal Jittering
"OK, I'm game, what did you finally do to remove the jitter?"
Apr 25, 2013
Les M replied to Les M's discussion Camera Gimbal Jittering
"Hi Guys, Problem turned out to be induced interference on one or more of the cables. After trying quite a few routes, have finally found one where the gimbal doesn't "jitter" any more. Hope this helps others.... Les"
Apr 25, 2013
criro1999 replied to Les M's discussion Camera Gimbal Jittering
"after power the APM, go in Mission Planner and try to disable the 2 gimbal servos (there are 2 checkbox). wait 2 sec and enable again. it works on my case, it not more jitter after re-enable (is like an reset)."
Apr 11, 2013
Don H. replied to Les M's discussion Camera Gimbal Jittering
"Hi Les, I'm not going to much help here. I too have servos that appear to be searching. It happens on both servos. I did find that when I rewired the servo lines using the bec power and ground going to pin 7 on the output the search did…"
Apr 11, 2013

T3
Richard Boyhan replied to Les M's discussion Camera Gimbal Jittering
"The link to your gimbal actually shows a FPV equipment. Keep in mind you will never get all the vibration out completely. In the end you will need some software to help clean up the vibrations. Better quality gimbal helps as does a larger copter.…"
Apr 11, 2013
Les M posted a discussion

Camera Gimbal Jittering

Hi Everyone,I have recently fitted a gimbal & camera to my Quadcopter (APM 2.5/2.9.1) with a video link. It was just a cheap chinese one similar to this: http://www.ebay.com.au/itm/261102207365?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2649While it is working, the gimbal does "shake" or "jitter" when the quad is powered up. I can control the camera tilt with CH 6 on the Tx…See More
Apr 11, 2013

Profile Information

About Me:
50yo newbie to RC but a long time nerd!
Please tell us a bit about your UAV interest
Quadcopter - still learning
Hometown:
Sydney

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service